Section軟體

標籤: 暫無標籤

75

更新時間: 2013-09-04

廣告

Section軟體 -Section軟體簡介

  本系統是在Windows XP系統和MapGis6.7(B20051118)基礎上,以Microsoft VC++ 6.0為編程語言,MapGis 6.7 SDK為開發平台進行開發的地質圖件製作軟體。系統基於MapGis輸入編輯子系統強大的圖形編輯能力,添加專業的地質圖件製作工具,大大提高了地質圖件的製作效率,能夠很完美的轉換CAD數據格式為MapGis格式。地質數據採集系統採用Microsoft Access的MDB格式,自動計算繪製符合行業標準的MapGis格式地質圖件。

  本軟體完全免費使用。在使用過程中,如果是本軟體的缺陷造成你的損失,本人不承擔任何責任。一旦開始使用,視為你同意。

  本軟體可以自由複製傳播,但不可用於商業用途。

  操作演示請切換到「操作視頻」幫助頁面,網上下載高清有聲視頻。

  現Section版本具有的主要功能模塊:

  1、繪製剖面圖功能;

  2、繪製柱狀圖功能;

  3、輔助工具Ⅰ和輔助工具Ⅱ(CAD轉MapGis文件);

  4、其他功能(暫時未歸類功能)。

廣告

Section軟體 -Section快捷鍵對照表

  

Ctrl+A選擇相同圖元功能B選擇區
Ctrl +C複製圖元功能C選擇點
Ctrl +V粘貼圖元功能N選擇弧段
Ctrl +X剪切圖元功能V選擇線
Ctrl +Z後悔操作X選擇子圖
Shift+Z選多類型圖元功能Z選擇文本
Shift +C超級拷貝功能E擴展工具箱
Shift +V超級粘貼功能T系統工具箱
F2正交功能Del刪除選擇圖元
Tab全屏功能空格鍵捕捉功能
向右移動選擇圖元向上移動選擇圖元
向左移動選擇圖元向下移動選擇圖元
Y捕捉點圖元U捕捉節點及端點
Ii捕捉交叉點O捕捉垂點
P捕捉最近點[捕捉中點
滑鼠中鍵按住可以移動圖形滑鼠滾輪放大縮小功能
雙擊滑鼠中鍵復原窗口功能雙擊滑鼠右鍵取消所有操作,回到初始狀態


  (以上快捷鍵不區分大小寫),其它快捷鍵與mapgis相同。

  在編輯視圖中,如果狀態為準備狀態,按住Ctrl右擊,將彈出常用圖元編輯快捷菜單;按住Shift右擊,將彈出擴展功能快捷菜單。

廣告

Section軟體 -安裝與卸載

一、系統要求

  基礎軟體:MapGis軟體。推薦MapGis 6.7版本Build051118。

  系統支持:Section軟體支持Microsoft Windows 的2000, XP, Vista和 7系列的操作系統。(32位,64位未測試)。

  語言:支持中文,簡體。

二、下載

  進入地信網論壇和華夏土地網論壇下載最新版本的Section程序。

三、安裝軟體步驟

  1)對於Section單個程序:把section.exe和section.chm等放入MapGis67\program目錄內即可。

  2)對於獨立安裝包:(相對於單個程序文件,還包含了先前的各種自定義配置文件)

  第一步:雙擊運行安裝程序Section2010.exe,打開安裝嚮導頁面開始安裝Section軟體;

  第二步:仔細閱讀「許可協議」,點擊「同意」,繼續下一步安裝,否則點擊「取消」,退出軟體安裝;

  第三步:仔細閱讀「信息」,閱讀軟體重要信息,點擊「下一步」,繼續下一步安裝,否則點擊「取消」,退出軟體安裝;

  第四步:選擇安裝路徑:默認情況下,軟體安裝在系統的C:\MapGis67\program目錄下,單擊「瀏覽」可更改路徑;注意非默認位置時,目錄只要指向program的上級目錄,即mapgis67。

  第五步:請「選擇組件」,有完全安裝,簡潔安裝和自定義安裝3種供選擇。點擊「下一步」,繼續下一步安裝;

  第六步:在開始菜單文件夾中創建程序的文件夾名稱。點擊「下一步」,繼續下一步安裝;

  第七步:選擇附加任務:創建桌面快捷方式和快捷啟動欄快捷方式,以及Section關聯MapGis文件等。勾選所需選項,點擊「下一步」,開始準備安裝;

  第八步:點擊「安裝」。直至最後,不想在安裝完成後運行Section程序請去勾,點擊完成

廣告

4、卸載

  1)對於非安裝包:把section.exe程序和section.chm等文件刪除即可。

  2)對於獨立安裝包:打開控制面板,進入添加/刪除程序(Win7的為程序和功能)找到Section卸載項目,雙擊「Section卸載」或者右鍵菜單中的卸載

FAQ:

  1、 雙擊section.exe后出現 「無法啟動此程序,因計算機丟失basroot.dll……」的提示,程序不能使用?

  答:沒有在mapgis環境下缺少基本組件和動態鏈接庫,運行程序會出現此提示,把section.exe放入MapGis67\program目錄內即可。

0327d正式版0612

  軟體更新日誌

  1、修正不能刪除角度花紋有殘留的Bug;

  0327d(beta3)0530

  1、主要是優化代碼,加快啟動速度

  0327d(beta2)(0529)

  1、修正多處錯誤。

  2、優化程序。

  3、增加單文件圖層管理器。

  0327d測試版(0523)

  1、增加批量刪除屬性結構。

  2、增加保存系統參數。

  3、增加標尺顯示。(還存在問題)

  4、程序框架做了調整。

廣告

Section軟體 -切剖面圖過程

  完成剖面圖所需的步驟

  1、必需完成地形線賦高程。

  2、讀取地形數據。

  3、讀取鑽孔數據。

  4、讀取槽探數據。

  5、讀取地質信息。

  6、圖切剖面。

  1、 首先用Section打開工程文件,把所有文件設為編輯狀態,然後對地形等高線文件進行高程賦值——新建線屬性高程欄位(原MapGis需要這樣做,用Section剖面圖菜單下的自動賦高程不需新建此欄位(拖動操作))。

  2、把等高線地質區文件設為當前編輯文件狀態:即點擊勾選文件名前的複選框!

  3、選擇菜單剖面圖-讀取地形數據(現有3種方式,此選拉線讀取),沿著勘探線從開始處拉線到末端出現設置基本數據對話框(如下圖),這裡要注意地形圖比例尺剖面圖比例尺,默認是1:5000和1:2000。如果不是這個比例尺,改成你需要的比例尺。最低標高默認為-1,表示由軟體自動計算最低標高。也自己看情況調整。

  4、點確定后,就可以拉直線了,點滑鼠左鍵,不要鬆開滑鼠左鍵,移到你要的地方后(可用滾輪放大縮小),鬆開滑鼠左鍵。會彈出存儲數據成功對話框。點確定后,會在地形圖上出現一條紅色的剖麵線。

  5、選擇讀取鑽孔數據后,在鑽孔的位置點擊一下會在左側出現鑽孔數據輸入對話框。孔深單位為實際的米

  6、點存儲,就會存儲這個鑽孔的數據,如果你還有鑽孔,就繼續在另外一個鑽孔位置點擊一下,輸入數據,點存儲,如果沒有了,就點退出

  7、輸入探槽數據。選擇讀取探槽數據,在探槽起點的地方點擊一下,會出現探槽數據輸入對話框,輸入數據后,點存儲,如果還有探槽,就再到另外一條探槽起點點擊一下,輸入數據,點存儲,如果沒有探槽了,就點退出槽探長度單位為實際的米

  8、選擇讀取地質信息后,會在底部自動打開一個地質信息的窗口。在這裡你可以依次修改地層產狀,地層花紋,顏色,界線,接觸關係和接觸產狀。自己根據順序(雙擊可看見區閃爍)修改就是。這裡具體就不修改,然後點存儲退出

  9、最後,選擇菜單剖面圖圖切剖面后,剖面圖就出來了,這時會出現保存路徑設置對話框,設置好後點確定。剖面圖畫好了!!

  10、剩下的工作就是對畫出的剖面圖進行添加數據和修飾圖面了。

  大致的過程就是這樣的。希望能對大家有所幫助。

  (以後的版本部分菜單名稱會有所改變,但基本過程不變)

廣告

Section軟體 -輔助工具Ⅰ

  輔助工具包含以下功能命令:

  文字對齊方式:對點圖元進行左對齊、右對齊、上對齊、下對齊,水平平均分配、垂直平均分配以及高(寬)度自動相等e.g.。

  導入導出功能:把當前的點、線、面文件屬性導出到EXCEL表格或者txt文件;導入屬性;以及參數與屬性之間的轉換;連接屬性(xls & WB);DBF轉表格WB。

  表格數據投影:投影EXCEL表的坐標數據到MapGis中,可以投影選中的部分數據,亦可以投影表格的全部數據。

  距離角度量算:即顯圖上距離,總長度,直線角度。

  距離角度修改:線按長度、角度修改。

  面積量算:量算面積。

  超級拷貝/粘貼:可以在不同工程之間、不同文件中、非同步文件中,不同位置可以自由複製粘貼。

  角度陣列複製:角度陣列複製點、線、區(區功能暫未完成)。

  插入/保存圖簽:插入系統圖簽和自定義圖簽。保存自定義圖簽。

  Excel與Mapgis互轉:Excel的線和數據轉到MapGis裡面,亦可反之。

  Excel與WB數據互轉:Excel數據互轉為WB數據格式。

  等高線設置:設置等高線參數。

  插入等高線:分直接插入等高線和四點插入等高線。

  選線/區充填線:選擇線或者區來填充線。(菜單,剖面圖-剖面圖修飾)

  常用岩層/岩體代號:岩體代號保存於stratum.sec,常用地層代號保存於stratum.sec,用戶可以自行打開設置。

  常用子圖符號:常用子圖符號保存於sub.sec,用戶可以在軟體中或後台編輯此文件。

  文字正體斜體:格式化文字的字形-正體和斜體。如按文字正斜體編寫常用代號,插入代號時會直接變成斜體或正體。

  裁剪工具:裁剪指定範圍的(工程)文件,且可以勾選裁剪完畢自動生成圖框

  剪斷相交線:選擇線剪斷相交線或者直接拉一條線剪斷相交線,自相交及節點斷線。

  等分線:定距離或定段數等分一條線。還可以隨機按偏移量自動等分線。

  圖元篩選:根據參數或者屬性篩選圖元,還可選擇相同的圖元。

  格式刷:把參數或者屬性結構(屬性值不會)賦值給選擇的圖元。

廣告

1、超級拷貝粘貼

  注意問題:

  1、本功能可以在不同工程之間、不同文件中,不同時間,不同位置自由複製粘貼(section打開就可以)。即便是複製后,再打開其他文件,也可以粘貼。

  2、完美支持超級複製粘貼,即使是區有問題,也能完美複製。

  操作步驟:1、點菜單,輔助工具1->超級複製。框選你要複製的內容,點基準點按鈕(基準點不要離你框選的圖元太遠)確定基準點后,再點對話框中的超級拷貝按鈕,就複製了這些內容。2、然後用section打開你要粘貼的文件或者工程,點菜單,輔助工具1->超級粘貼。任意點擊就拷貝到該處,或者還可以選擇基準點改變位置,這裡的基準點和超級複製的基準點對應。

2、Excel與MapGis數據互通

  注意問題:

  1、如果先打開了Excel表,則會插入表中選擇的數據到MapGis圖形中;若事先未打開Excel,那麼將會把選擇的表(Sheet)中的所有數據(直到最後為空值行;有空數據行但下面仍有數據行,繼續插入數據;有引用公式當做有數據)轉到MapGis裡面;

  2、如果需要把Excel中的線也輸入到MapGis中,請先設置好表格中的線,且能輸入單元格的文字字體、顏色、大小等;

  3、如果要自定義表格轉到MapGis範圍大小,在點菜單Excel->MapGis后,框選輸入數據的範圍,數據輸入MapGis後會自動調整數據(文本,表格)大小。

  4、在較多文字的時候,如果一行寫不下,將自動轉為版面輸出(和上一點說明的情況不同)。

  操作步驟:

  1、 執行菜單「1輔助工具\導入導出功能\MapGis<> Excel\Excel->MapGis」,然後滑鼠左鍵點擊會把當前Excel中選中的線和數據轉到MapGis裡面;如果未先打開Excel會彈出對話框選擇插入的Excel文件,該文件有多個表時又會提示選擇插入的表名。

  2、 執行菜單「1輔助工具\導入導出功能\MapGis<> Excel\MapGis-> Excel」,然後滑鼠框選輸出數據區域即可,自動打開Excel並且點數據輸出到Excel,線數據表現在單元格的合併上;

  3、 執行菜單「1輔助工具\導入導出功能\MapGis<> Excel\MapGis-> Excel1」,然後滑鼠框選輸出數據區域即可,自動打開Excel並且點數據輸出到Excel,線數據不輸出;

  備註:a、MapGis-> Excel輸出數據時,點線文件必須處於編輯狀態,否則不成功,點的樣式與MapGis中的一樣

  b、MapGis-> Excel1輸出數據時,只要點文件處於編輯狀態下既可以,本功能是按照文字位置排列輸出到Excel表格,所以樣式與MapGis中的會不同。

  FAQ:

  1、MapGis數據轉入Excel后表格內容為空白什麼原因?

  答:可能原因是轉的時候沒有正常關閉com介面,可以關閉Section,重新打開Section再試試,或者打開任務管理器,關閉所有Excel進程。

  2、Excel單元格數據轉入MapGis中的單元格實際寬度和高度的換算公式?

  答:MapGis單元格的寬度=(127.0÷60.0)×(Excel單元格寬度)+(127.0÷96.0);

  MapGis單元格的高度=(127.0÷360.0)×(Excel單元格高度);

3、插入等高線

  注意問題

  1、分四點插入等高線和直接插入等高線。

  2、四點插入等高線必需先選擇兩條線(若未先選擇線當點擊完第三個點時即彈出對話框,且插入會失敗),然後在線上點四個點,前兩點在一條線上,后兩點在另外一條線上。如果出現亂線,先改一條線的方向再試。

  3、直接插入等高線,不一定先選擇兩條線,可以先點工具后再選擇線,也不要改線方向。

  操作步驟

  1、 執行菜單 「1輔助工具\插入等高線」,接著拉框選擇兩條線。彈出等高線參數設置對話框后,內容如下:

  線拐點,只針對1演算法,點越多,線插入更好。

  等高線數:插入等高線的數量。填充線角度和填充線距離,只是區域填充線功能參數。

  演算法1:適應兩條線結點比較平均的線,演算法2:適應拐角較少的兩條線,演算法3:適應拐角較大的兩條線。

  2、先按V,接著拉框選擇兩條等高線,然後執行菜單 「1輔助工具\四點插入等高線」,依次在兩條等高線上點擊,當點擊完第四個點時,彈出等高線參數設置對話框后,設置同上(此略)。

4、圖元篩選

  注意問題

  1、 包括參數篩選圖元和屬性篩選圖元。本功能不可跨文件使用,只對當前編輯狀態(或單文件打開)的文件有效。

  1、 如果需要多次篩選,可以勾選「是否從選擇集中篩選」。

  操作步驟

  執行菜單「1輔助工具\參數(屬性)篩選」,彈出篩選圖元對話框:

  A、對於參數篩選圖元:在篩選圖元對話框中①列表框中選擇圖元類型;②然後在右側的參數選項中選擇一個參數項作為篩選參數;③再選擇運算符及其值。確定后符合該參數條件的圖元既被選中閃爍。

  是否從選擇集中篩選:指在參數篩選后的選擇集中再次篩選,默認否。運算符-全部:選擇此項后,指可以不選擇。指滿足所有參數欄位的條件。比如顏色是指全部顏色。

  B、對於屬性篩選圖元:在篩選圖元對話框中①列表框中選擇圖元類型——當前點//區文件,再點確定;彈出表達式輸入對話框②然後在欄位名稱下面選中一個屬性欄位作為篩選屬性;③接著點擊操作符區的運算符按鈕,並且輸入其值(比如ID==45)。確定后符合該參數條件的圖元既被選中閃爍。例如:選擇大於等於730高程值,且每隔20米的所以等高線。在表達式輸入框中輸入表達式:(高程-730)%20==0

  操作符的含義:

  

符號代表意思示例符號代表意思示例
+5+8=13<=小於等於ID<=5
8-5=3==等於ID==85
×5×8=40!=不等於ID!=66
/8/5=1.6&&4&&8
%求余8%5=3||3||5
>大於ID>5^次方2^3=8
>=大於等於ID>=5!!3
<小於ID<5in包含於10in100

5、相同圖元

  注意問題:

  1、相同類型圖元是指子圖號、線號、區顏色相同。該功能可以先選擇圖元再執行命令,亦可以先執行命令再選擇圖元。

  操作:

  1、 執行菜單「1輔助工具\相同圖元」或者直接使用快捷鍵Ctrl+A,有以下一些區別。

  A、直接點選圖元,選擇相同類型圖元;

  B、按住Ctrl點選圖元,選擇相同類型,相同顏色圖元;

  C、按住Shift點選圖元,選擇相同類型、大小圖元;

  D、按住Ctrl+Shift點選圖元,選擇相同類型、顏色、大小圖元。

Section軟體 -輔助工具Ⅱ

  輔助工具包含以下功能命令:

  查圖元文件名:查看圖元存放於哪個單文件內。點選圖元即可彈出信息提示。

  平面工程投影:主要是來投影探槽和硐探。

  畫勘探線繪製勘探線;定角度定長度畫直線;精確繪製導線。提供三種方法,單擊「繪製勘探線」複選框切換。

  平行垂直線對選定的某線(折/曲)畫平行線或垂直線。單擊「造平行線」複選框切換為造垂直線。

  剖面圖補充:(新建文件) 讀取完工鑽孔數據和讀取平面數據;充填線。在剖面圖形成后,讀取資料庫裡面的完工鑽孔/平面工程數據。

  實體號賦ID號:(單文件或新建文件)實體號賦值給ID號。某子圖的ID號有重複,自動重賦ID號。先壓縮保存工程再單獨打開該文件執行命令即可。

  自動合併區:自動合併符合參數條件的鄰近區。

  刪除重疊圖元刪除參數相同的完全重疊的點、線、區子圖文件。

  選擇點圖元可以利用閉合線、區或者滑鼠自定義圈閉來選擇圖元。

  選擇框外圖元:可選擇框選外的圖元(點線面)。執行命令後用滑鼠框選區來選擇框外的圖元。按Del鍵可以刪除框外的圖元,這也可以刪除飛點飛線。

  刪除飛點飛線如果圖形中存在飛點飛線,圖形就會 「複位窗口」不能滿屏顯示(打不開),或輸出系統中1:1情況下幅面大小大於實際幅面大小,這多為飛點飛線造成的,這時可以使用這個功能。

  註釋賦給子圖可以把在註釋一定範圍(列表中的單位為mm)內搜索子圖並且賦值給子圖,並自動建立「標註」欄位存儲註釋。

  註釋賦給圖元把註釋賦值到圖元屬性(需先編輯建立屬性結構),再點選圖元賦值。

  自動增量標註設置好自動遞增格式后,一直點擊標註處。如D15*,起點1,步長2,位數2,則如D1501、D1503、D1505……

  縱剖面投影(還不是很完善)

  自動生成樣軌是利用線的節點生成,樣軌寬度用戶決定,單位為mm。點線哪側就會在哪側自動生成區填充色為黑白相間的樣軌。

  屬性簡單計算圖元屬性值簡單計算。

  高程屬性賦點:把等高線屬性的高程欄位複製到點屬性的高程欄位。執行命令后彈出搜索範圍對話框,單位為mm。

  線高程自動標註等高線的高程欄位值自動標註,拖動后符合條件的即自動標註。

  CAD轉MapGis文件(需要新建文件)導入DXF文件(2004版本格式更好)或明碼文件,另存為DXF文件或明碼文件。DXF文件可用Acme CAD Converter轉換得到。

  拾色賦圖元拾取屏幕顏&#91;局限在軟體區域內&#93;色賦給圖元(包括點、線、面)。

  圖形局部變換對框選區域進行圖形變換。

  FAQ:

  1、 為什麼有些功能,比如鑽孔柱狀圖、讀取DXF文件、實體號賦ID號等需要新建文件才能使用?

  答:繪製圖形的時候,會在工程文件或編輯狀態的單文件中繪製圖元,會破壞這些文件中的類型等,不利於文件的分類管理。

1、區屬性多欄位標註

  問題:

  1、如果未先製作自定義形狀,在勾選使用自定義形狀時會彈出「無法打開AttLabel.sec文件」的提示。

  操作步驟:

  1、執行菜單「2輔助工具\區多欄位標註\區多欄位標註」,彈出區屬性多欄位標註對話框:左側示意圖區,中間為屬性欄位選擇區,右側為控制參數設置區。

  屬性欄位:圖示區中的序號與屬性欄位前的序號向對應,該屬性欄位內的數據將會顯示在圖形上。屬性欄位內容順序由用戶決定。

  圖形控制參數:設置圖形的顯示形狀(長方形或橢圓)及其高度、寬度,圖形上顯示的數量上限(會自動根據區的屬性欄位變化),字元大小。

  模板:模板1為平均分配型,模板2為菱形型。

  使用自定義形狀:使用用戶自定義的形狀標註。需要用戶先製作形狀,並讀取到內存中。

  2、選擇部分區多欄位標註的操作方法是:先選擇區(點擊手型選擇按鈕,再按住Ctrl鍵逐個單擊),然後執行此命令。

  製作自定義形狀

  1、製作方法同自定義圖簽。這裡的形狀需要依次標註順序號1、2、3……(根據你畫的格子)。製作完成後再框選、保存自定義形狀。

2、CAD轉MapGis文件

  注意問題:

  1、 cad_map.pnt(原MapGis對照表為arc_map.pnt)為CAD塊與MapGis子圖對照表,如果有CAD塊沒有在對照表中,暫時不能轉換。cad_map.lin(原MapGis對照表為arc_map.lin)為cad線型與 MapGis線型對照表。

  2、 圖元顏色和層號採用自動轉換,不需要做對照表。

  3、 塊文件等不需要做炸開處理;能很好的支持樣條曲線。先清除dxf裡面本身的飛點飛線。

  4、 CAD連體但單獨存在的填充,轉到MapGis時將全部轉為獨立的區。

  5、 如果CAD是三維圖,需要把拉伸圖元變成正常圖元,不然會造成飛點飛線。

  6、 區花紋暫時不能轉換。

  7、 讀取該DXF文件時,退出其他程序使用該文件,讓Section獨佔使用該文件。

  讀取DXF文件,操作:

  1、將AutoCAD的DWG格式(推薦2004版本的),轉換為AutoCAD的數據交換格式DXF(如R12 dxf,最好選擇dxf2004版本的);轉換DXF文件時,不需要對原圖的塊(符號)作爆破處理。大家亦可以使用Acme CAD Converter軟體轉換為「AutoCAD 2004 DXF格式(*.dxf)」。

  2、然後編輯對照表文件。由於CAD和MapGis的兩種數據結構不一樣,導致CAD格式數據轉換成MapGis數據時發生「張冠李戴」的現象,兩種的圖形數據無法對應。系統提供了一套圖元對照表,文件位於安裝目錄的section文件夾下,用戶可以根據自己的需要進行修改編輯,使用說明如下:

  cad_map.lin為線型對照表:前面是CAD線型名稱代號,後面的為MapGis線型代號,中間至少需用一個空格隔開。

  cad_map.pnt為塊和子圖對照表:前面為CAD塊名稱代號,後面為MapGis子圖代號,中間至少需用一個空格隔開。

  3、執行菜單「文件\新建文件」,先新建文件(非新建工程哦)。

  4、執行菜單「2輔助工具\打開外部數據\讀取DXF文件」,然後提示是否「讀取塊定義數據」,選擇后即開始轉換,等待片刻轉換完成。

  5、執行菜單「工作區\存文件\存點(/)文件」,依次保存點、線、區文件。

  FAQ:

  1、 如何查看DXF文件是否存在飛點飛線?

  答:CAD中點擊滿屏工具 出現看不到圖的話就說明是有飛點飛線了。

  2、 轉換一段時間后,看不到圖元怎麼回事?

  答:①轉換時文件被其他程序使用著;②沒有轉換成功,沒有圖元;③有圖元,有飛點飛線;解決:①重新按要求轉換;②可能DXF文件有問題或程序無法識別轉換,請用其他軟體轉換試試;③保存文件后再刪除飛點飛線。

Section軟體 -其他功能

1、文字查找替換

  操作步驟:

  1、 執行菜單「點編輯\修改文本\文字查找替換」,彈出文字查找替換對話框:

  當前文件:指只對處於當前編輯狀態的文件有效。

  編輯文件:指凡是處於編輯狀態的文件有效。

  條件選擇:勾選彈出文字參數替換開關對話框界面:設置文字註釋的高、寬、角度、字體、顏色、圖層等參數。即查找替換滿足此處設置的文字參數的對象。

  是否替換:默認不勾選,即只查找不替換。需要使用替換功能請勾選。

  整串查詢:是指符合當且僅當指定文字串的才能查找或替換。默認不勾選,指凡是包含字元串條件的即被查找或替換。

  工具欄搜索框:為文字查找功能&#91;凡是包含字元串條件的即被查找或替換&#93;,輸入字元后回車執行,找到文字後會閃爍顯示。如果輸入的字元與快捷鍵有衝突的字元會被屏蔽無法輸入,請使用大寫鎖定鍵或者請在別處輸入后複製到搜索框。

2、坐標顯示

  注意問題:

  1、 顯示實際坐標操作的前提是你的圖是標準圖框生成的或者經過標準圖框校正的。

  2、 圖形經緯度顯示需要先設置比例尺后再設置投影參數,或者先有設置地圖參數,則不需再設置投影參數,直接雙擊狀態欄的實際坐標選擇經緯度就可顯示經緯度。

  操作步驟:

  1、設置比例尺。執行菜單「設置\設置比例尺」,或者單擊狀態欄最右下角比例尺文字,彈出圖形比例尺對話框,在列表中選擇比例尺的分母,確定后在狀態欄的實際坐標區會即時顯示滑鼠當前的實際高斯坐標。

  取消顯示實際坐標功能,再次執行此命令,在圖形比例尺對話框中不要做選擇操作,直接確定即可取消顯示實際坐標。

  2、經緯度顯示。雙擊狀態欄的實際坐標區,彈出信息提示窗口(yes為經緯度顯示,no為高斯顯示)。

  Yes后彈出①輸入地形圖投影參數:依次設置投影類型、橢球參數、單位、比例尺分母、投影中央經度(投影帶類型和代號),完成設置后確定②輸入經緯度投影參數:選擇地理坐標系、橢球參數、坐標單位DDDMMSS.SS,確定后在狀態欄的實際坐標區會即時顯示滑鼠當前的經緯度。

3、圖幅號轉換

  操作步驟:

  1、打開工程文件時,執行 菜單「窗口\圖幅號轉換功能」;打開單文件時,執行 菜單「顯示\圖幅號轉換功能」。彈出新舊圖幅號轉換對話框。

  用戶可以根據需要選擇比例尺,經緯度(度)、經緯度(度分秒)、新舊圖幅號形式轉換。右側顯示圖幅範圍。

4、造定角度方位線

  注意問題:

  1、 部分功能與「2輔助工具\畫勘探線」的精確制導功能類似。使用該功能可以實現精確製圖。

  2、 角度以正東方向為0°,逆時針增加,角度值大於0°;與精確制導的角度(角度以正北方向為0°,順時針增加)正好相反。

  3、 在退出該命令(點擊其他命令)前,可以另起線段一直輸入長度和角度造線。期間不需要滑鼠點擊輸入框。

  操作步驟:

  1、 點擊工具欄的「造定角度方位線」按鈕,然後在需要位置處點擊,在左上角彈出長度和角度的懸浮框:

  長度:從起點處開始的該段線段的長度,為圖上距離,單位mm;

  角度:該處角度現在只能輸入正角度(≥0°)(可以輸入小數位)。

  (如果只輸入長度數據,不輸入角度數據,則角度默認為0)

  2、 直接輸入、修改長度和角度數據使用↓↑方向鍵進行切換(或者滑鼠定位到輸入框中輸入數據,滑鼠焦點移出輸入框后回車)。 如果數據輸入錯誤,請按退格鍵向前刪除一個數據,或者Del鍵刪除當前行數據。閉合線請按住Ctrl右擊即可。

  3、 如果想反悔,還可以直接按F9回撤到上一點。

5、曲線轉樣條曲線

  注意問題

  1、 該命令只能先選擇命令再選擇曲線。本功能非可逆操作,轉換成樣條曲線后無法轉回原形的折線。

  操作步驟

  1、先更改線參數的線類型為曲線。非曲線務必先改成曲線!(折線可以直接轉樣條曲線,但曲率變化不均)

  2、再點擊工具欄畫線按鈕旁向下的箭頭,在下拉的列表中選擇「曲線轉樣條曲線」,然後選擇曲線。。

  FAQ

  1、什麼是樣條曲線,作用?與MapGis中的光滑曲線有何區別?

  答:樣條曲線是經過一系列給定一組控制(多邊形)點而得到的光滑曲線。樣條曲線是以數值計算的方法,用逼近控制折線多邊形的光滑參數曲線段構造出一條光滑曲線。/樣條曲線一般用來構造物體的表面,進行自由曲線、曲面造型和實體造型。/MapGis中的光滑曲線其實還是折線,這個光滑曲線(折線)在角度改變較大時可以看見有稜角。而樣條曲線則能精確表達圓錐曲線曲面,讓人覺得非常光滑平緩,曲線很連續、曲率變化均勻。(當然無限放大時樣條曲線也能看見稜角)

  2、 為什麼樣條曲線無法轉回折線的原來形狀(改參數)?

  答:因曲線轉樣條曲線時增加了許多節點,因此就無法轉回折線原來的形狀了。

Section軟體 -鑽孔柱狀圖

1、鑽孔柱狀圖完成 基本 所需的操作順序

  一、數據採集部分:

  (不要忘了這一步:點擊文件->新建文件(注意不是新建工程),再點柱狀圖菜單->連接數據源。)

  1、新建礦區。這個完成後會在「數據採集」菜單下的「礦區信息」查看。視頻

  2、鑽孔地質編錄:又有些許小步驟如下

  1)填寫鑽孔基本信息。滑鼠焦點定位於礦區代碼中,滾動可以切換礦區。視頻

  2)地質編錄。這裡數據比較多,而且編輯輸入都不便,你可以參考MDB與XLS的編輯及導入複製內容到這裡或者導入數據。視頻

  3)地層信息。地層的起止孔深,地層名以及地層顏色代號。

  4)標誌面。填寫層號、孔深、標誌類型及產狀。

  5)標本庫。填寫採集的標本編號、孔深及類型。

  6)鑽孔測量。鑽孔彎曲度測量數據。

  7)孔深校正。鑽孔孔深校正數據。

  8)水文數據。封孔情況(封孔段的位置與材料)、水位變化(開鑽以來的水文觀測數據)、水文描述、富水性。根據需要填寫。

  9)測井數據。

  10)化學元素信息。該礦區或鑽孔有分析的相關元素,需要在這裡填寫,其他地方會以F1、F2、……表示

  11)基本分析樣。採樣分析的編號、位置、長度及元素分析結果。

  12)單工程圈定。綜合分析,圈定的礦體工程位置。

  3、剖面信息:需要填寫剖面基本信息和剖面樁號信息。

  4、測井數據。不太用到,需要用到這個的自己鑽研了。。。

  5、花紋庫維護。&#91;編輯花紋庫代碼表視頻&#93;

  6、數據邏輯檢查。數據完成後最好利用這個檢查下,能為你查處一些錯誤。這裡有的可能有些錯誤,如果你肯定你的沒有錯誤后就不用理會提示。

  7、數據預處理。這個是輸出鑽孔前必須做的!多預處理幾次吧,這樣對你會有好多的。

  8、參數設置。此處用於輸出圖形的顯示和列印選項。如果默認的不夠你用,或者多了,在這裡打開關閉吧。

  二、圖形輸出部分:

  數據採集完成後進入輸出圖形,需要關注一下一些信息:

  1、 柱狀圖路徑:設置柱狀圖輸出的路徑及名稱。如果未設置,最後關閉時會提示保存文件。

  2、 柱狀圖參數:表頭高度、內外框線線寬和制定壓縮符號。

  3、 設置表頭(文件保存於ZKTablerHead.sec,只能在軟體中修改)。視頻

  4、 輸出圖形:主要為描述部分的分配位置

  1) 繪製柱狀圖;

  2) 自定義柱狀圖輸出。

  操作視頻

  高清有聲視頻下載地址

  輔助工具1的部分視頻下載地址:

  

角度修改avihttp://u.115.com/file/f715406d7c
格式刷avihttp://u.115.com/file/f775fbe517
超級拷貝粘貼avihttp://u.115.com/file/f7e578d9a5
裁剪工具avihttp://u.115.com/file/f79273ca1a
(高斯)表格數據投影avihttp://u.115.com/file/f7b6a78bf
導入屬性數據avihttp://u.115.com/file/f7596fb79
連接屬性數據(Excel)avihttp://u.115.com/file/f7e2ded87f
點位置轉換為屬性avihttp://u.115.com/file/f77be60714
導出屬性數據(Excel)avihttp://u.115.com/file/f7ce537a1
導出選擇數據屬性avihttp://u.115.com/file/f7e5c19473
(經緯度)表格數據投影avihttp://u.115.com/file/f7ff3aed00
屬性篩選avihttp://u.115.com/file/f760fc5f78
參數篩選avihttp://u.115.com/file/f7b87100c1
參數與屬性的轉換avihttp://u.115.com/file/f72e619495
插入等高線1avihttp://u.115.com/file/f7237f68ce
插入等高線2avihttp://u.115.com/file/f79fd31ab0
輔助工具2的部分視頻下載地址:

  
自動合併區avihttp://u.115.com/file/f79fdb3686
線高程自動標註avihttp://u.115.com/file/f754b60c16
區多欄位標註Avihttp://u.115.com/file/f780ff1daf
自動生成樣軌Avihttp://u.115.com/file/f76f04bed2
畫勘探線avihttp://u.115.com/file/f7501bc67c
平行垂直線avihttp://u.115.com/file/f747db6dca
自動增量標註Avihttp://u.115.com/file/f74e8db9b2
註釋賦給子圖avihttp://u.115.com/file/f735beb430
註釋賦給圖元AVIhttp://u.115.com/file/f7abdb1fd0
查看圖元文件名。rmvbhttp://u.115.com/file/f7af9d7d87
讀取DXF文件avihttp://u.115.com/file/f7470f5021
圖切剖面的部分視頻下載地址:

  
設置圖簽參數avihttp://u.115.com/file/f7541eacfa
修飾剖面avihttp://u.115.com/file/f7ca7b225c
讀取鑽孔數據avihttp://u.115.com/file/f72a8ec1ac
圖切剖面一avihttp://u.115.com/file/f75d8bf11d
圖切剖面二avihttp://u.115.com/file/f7be9faa46
插入等高線avihttp://u.115.com/file/f7cf05d5c8
增加完工鑽孔avihttp://u.115.com/file/f71e62e95f
讀取地形數據avihttp://u.115.com/file/f76967d8ec
圖切剖面命令avihttp://u.115.com/file/f753261549
設置剖面圖參數avihttp://u.115.com/file/f7cd8189ab
自動賦高程avihttp://u.115.com/file/f7e67ea312
讀取地質信息avihttp://u.115.com/file/f7917b92a7
讀取平面數據avihttp://u.115.com/file/f776f3b79e
讀取探槽數據avihttp://u.115.com/file/f798ed56c9
鑽孔柱狀圖的部分視頻下載地址:

  
設置鑽孔表頭及生成柱狀圖avihttp://u.115.com/file/f7ee6b822a
導入整個表格數據到Access資料庫中avi.http://u.115.com/file/f7704fecca
複製方法xls數據導入MDB資料庫avihttp://u.115.com/file/f761cddc52
新建礦區avihttp://u.115.com/file/f7f8d70bb7
鑽孔基本信息avihttp://u.115.com/file/f78fd43b24
編輯花紋庫代碼表avihttp://u.115.com/file/f7ef96b506
連接數據源avihttp://u.115.com/file/f71114fec1
地質編錄avihttp://u.115.com/file/f770557565
資料庫導出DRILGEO2表數據為xls格式swfhttp://u.115.com/file/f775445ce
Access導出數據到Excel中Avihttp://u.115.com/file/f7f5fbd7c1
導入數據及相關設置。swfhttp://u.115.com/file/f782fee756
其他

  
文字查找替換avihttp://u.115.com/file/f72f7262cf
文件關聯avihttp://u.115.com/file/f75f4c7644
造定角度方位線avihttp://u.115.com/file/f714db54c6
曲線轉樣條曲線avihttp://u.115.com/file/f7fad4f5ec

廣告

廣告